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Getting Started

Introduction
Ultrasoft® DataShield lets you organize and store your important 
information conveniently and securely on your Microsoft® Windows® 
computer and synchronize it with your Palm OS® handheld computer, so 
you can access your data when you need it, wherever you are.
And DataShield doesn't just store and protect your information — it helps 
you manage it.
• Convenient — Store birthdays, policy numbers and membership 

details. Attach notes and schedule reminders on your handheld to let 
you know when things need attention.

• Secure — Store account numbers, PINs and passwords. DataShield 
uses military-strength encryption to keep your information safe in its 
password-protected database.

• Flexible — Use the built-in templates to organize your data, or create 
your own templates. Select your own security settings to give you the 
right balance of convenience and protection.

• Simple — You don't need to be a database programmer to configure 
DataShield just the way you want it. You can start entering your data 
within seconds.

Starting Ultrasoft DataShield
To open Ultrasoft DataShield on your Windows computer, click the 
Windows Start button, then choose Programs and Ultrasoft DataShield. 
The first time you open DataShield, it may ask if you want to create a new 
database and/or set a password. It will then display the Record View and 
you can immediately begin entering your data.
If you plan to synchronize DataShield with your Palm OS® handheld, see 
“Steps for Using DataShield” on page 6 before you run the desktop 
program.
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Setting a Password
A password is used to protect your data. You must enter the password to 
access DataShield on your Windows computer.

IMPORTANT: Do not forget your password. It cannot be recovered. See 
“Changing Your Password” on page 31.

You can use the same DataShield password on your Windows computer 
and on your Palm OS handheld. DataShield can be configured to keep 
your password synchronized on the two platforms. See “HotSync 
Options” on page 35.

Steps for Using DataShield
Step 1: Installing Ultrasoft DataShield
Step 2: Entering Your Data
Step 3: Using Ultrasoft DataShield
Step 4: Backing Up Your Data

Step 1: Installing Ultrasoft DataShield
Download and run the Ultrasoft DataShield setup program on your 
desktop computer. The setup program will install DataShield on your 
computer and on your Palm OS® handheld computer.

The setup program will allow you to select the optional template and icon 
databases. When the setup program is finished, synchronize your Palm 
OS® handheld computer to install the software. The synchronization 
process will create linked databases that will be used to share 
information between your PC and your handheld.

Step 2: Entering Your Data
After installing Ultrasoft DataShield you can immediately begin entering 
your important data using the provided templates. To get started, see 
“Creating and Editing Data Records” on page 14.
You may also want to create your own templates, or modify the provided 
ones. See “Creating and Editing Templates” on page 24.
You can enter data either on your PC or on your handheld. When you 
synchronize, your entries will appear on both platforms. See 
“Synchronization” on page 33.
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Step 3: Using Ultrasoft DataShield
Ultrasoft DataShield allows you to:
• Create and edit data records
• View your data
• Control the level of data security
• Schedule reminders on your handheld when items need attention
• Backup your data to your desktop computer

Step 4: Backing Up Your Data
Any changes to your Ultrasoft DataShield data on your handheld are 
automatically backed up to your desktop system whenever you 
synchronize.
To back up the DataShield database on your desktop, use the Backup 
menu command. See “Backing Up Your Data” on page 20.

Getting Help
You can access this User’s Guide from within DataShield for Windows by 
selecting the Help menu option, or pressing the F1 key.
Additional help is available on-line. See “Getting Help” on page 39.
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Managing Your Data

Overview
The Ultrasoft DataShield window includes several panes.

• The toolbar is displayed beneath the menu, and contains buttons for 
frequently used menu commands.

• The shortcut bar is intially displayed at the left side of the window, 
and displays shortcuts to the Template and Record list views.

• The list view pane in the middle shows the Template or Record list.
• The preview pane displays data for the selected template or record.
• The status bar at the bottom of the screen displays status messages 
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The toolbar also contains the HotSync User selector. If your computer 
hosts several HotSync users, you can choose the HotSync ID from this 
drop-down list.

Arranging the Window Layout
The toolbar, shortcut bar and preview pane can be moved, resized, hidden, 
dragged away from the main DataShield window and left to float on their 
own, or docked at any edge of the main DataShield window.
Use the View menu commands to hide or show the toolbar, status bar, 
shortcut bar and preview pane, or to select the Template or Record view.
By default, DataShield memorizes window placement and pane selection. 
To disable this feature, or to further customize the window layout, toolbar 
contents, keyboard shortcuts or other workspace attributes, use the 
Customize command in the Tools menu.
To reset the workspace layout to its “factory default”, use the Reset 
Workspace command in the Tools menu.

Viewing Your Data

The Record View
The Record View displays your data records. You can choose to have 
DataShield either display or mask your encrypted data in the list. See 
“Security Preferences” on page 29.

To access the Record View, click the Records icon in the shortcut pane, or 
select Records from the View menu.
The list displays each record’s description field, its designated display 
value, and icons to indicate if the record has an associated alarm or note, 
and if it’s marked Private or Archived.
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Data records that are marked Private can be hidden or masked in the list 
using the Private Record options in the View menu. See “Record Details” 
on page 15. Records that are marked Archived are not synchronized with 
your Palm OS handheld, and can be exported and removed using the 
Archive command in the File menu. See “Record Details” on page 15 and 
“Archiving Records” on page 20.

To customize the display of the Record View, use the Preferences 
command in the Tools menu.
You can filter the list by template type and by category.
• To change the template filter, click the type name located at the upper 

right of the pane and choose a template from the pop-up list. See 
“Using Templates” on page 23.

• To change the category, click the category name located in the upper 
left of the pane, and choose a category from the drop-down list. See 
“Using Categories” on page 19.

To create a new record, click the New button. See “Creating and Editing 
Data Records” on page 14.
To edit a record, double-click on its name in the list, or select the record 
and click the Edit button.

With the preview pane enabled, select a record in the list to display its 
details in the preview pane. From the Record Preview pane, you can drag/
drop fields to other programs such as Internet Explorer.

To delete a record, select it and click the Delete toolbar button, or right-
click the mouse on its name and choose the Delete command from the 
pop-up menu.
You can also select a record and use the main menu, pop-up menu, toolbar 
or keyboard shortcuts to cut, copy, paste, archive or print it.

Keyboard shortcuts are displayed in the menus. Mnemonics for buttons 
and other controls are indicated by an underlined character in the button or 
other caption. Windows XP users: press the Alt key on your keyboard to 
highlight shortcut mnemonics.
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Customizing the Record View
To customize the display of the Record View, open the Preferences 
dialog via the Tools menu and select the General tab.

The Preferences dialog also includes tabs that let you select security 
settings (see “Security Preferences” on page 29), configure your 
synchronization options (see “Setting the Synchronization Properties” on 
page 34), and input your DataShield registration code (see “How do I 
register Ultrasoft DataShield?” on page 38) .

• Click the Sort by drop-down arrow and select the sort order for the 
list: 
• Type
• Name
• Order Entered

• Click the Display columns drop-down arrow and choose the number 
of columns to be displayed in the main list.

• Check the Remember type and Remember category options to have 
DataShield memorize the type and category selections for the Record 
List view.

• Check the Enable hyperlinks in preview option to enable clickable 
hyperlinks in the Record Preview. See “Viewing a Data Record” on 
page 13.
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• Check the Hide unused fields option to hide unused fields in the 
Record View. Only fields that contain data will be displayed. See 
“Viewing a Data Record” on page 13.

Viewing a Data Record
Click on a data record in the Record View to display its details in the 
preview pane. The Record preview pane is illustrated below.

The record name is displayed over the color specified in its Record Color 
setting. See “Record Details” on page 15.
If the clickable hyperlinks option is enabled (see “Customizing the Record 
View” on page 12), hyperlinks values are shown in blue and underlined. 
You can click on the text tojump to the hyperlink.
If the record has a scheduled reminder, the reminder details are displayed 
on the Reminder tab. If it has a note attached, the note is displayed on the 
Note tab.

To copy a value to an input field in another program such as Internet 
Explorer, click your left mouse button on the field and drag it to the other 
program’s window, and release the button. The other program must 
support drag/drop operations.
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Creating and Editing Data Records
Ultrasoft DataShield lets you view, create and edit data records using the 
Record View.
To create a new record, click the New button in the Record View.
To duplicate a record, click on its name in the Record List View and use 
the Copy and Paste menu commands. Duplicating and modifying an 
existing record can be a quick way to create a new record.
To edit an existing record, click on the record in the Record View, then 
click the Edit button. When you edit or modify a record, the new 
information replaces the previous information.

Record Data Values
When you create or edit a record, the Record Edit View is displayed.

When you create a new record, its fields and default settings are based on 
the currently-selected template. See “Using Templates” on page 23.

TIP: If you plan to create several new records, select the category and 
template in the List View first. When you click the New button, the 
category and template will be pre-selected, and the cursor will appear in 
the Description field ready for you to start typing.
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Click the Type drop-down list and choose a different template to change 
the record’s template. When you select a different template, the record’s 
field values are re-mapped to the new template.
Enter data values into the appropriate fields using the keyboard or 
highlight text in another program that supports drag/drop (such as the 
Palm Desktop application), and drag it to the input fields using your 
mouse.

NOTE: When you create or modify a record, its fields are encrypted 
based on their corresponding setting in the template. See “Using 
Templates” on page 23.

Click OK to save the record, or Cancel to discard your changes.

Record Details
Click the Details tab to view the record details.

Default values for the record details and reminder schedule are inherited 
from the record’s template. See “Using Templates” on page 23.
• Click the Show in List drop-down arrow and select a field to be 

displayed in the second column of the Record View. The record’s first 
field (usually the Description field) is always displayed in the first 
column.

TIP: If you’ve already 
begun to enter data, you 
can select a different 
template without losing 
your entries.
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• Click the Category drop-down arrow and select a category for the 
record. See “Using Categories” on page 19.

• Click the Record Color and Record Icon selectors to choose a color 
and icon for the Record View display. See “Viewing a Data Record” 
on page 13.

• Check the Searchable option to make the record searchable on your 
handheld using the Palm OS® Find function.

• Check the Private option to mark the record as private. Use the 
Private Records setting in the View menu to specify whether private 
records should be shown, hidden or masked.

• Check the Archive option to mark the record as archived. Archived 
records are not synchronized with your Palm OS handheld. See 
“Archiving Records” on page 20.

Record Note
Click the Note tab to view the record note.

Use a note to store any information that doesn’t belong in a field, or to 
make special notes about the record.

TIP: To enter a tab character in the note field, type Ctrl-Tab.
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Record Reminder
Click the Reminder tab to view the record reminder schedule and 
message.

Default values for the record reminder schedule are inherited from the 
record’s template. See “Using Templates” on page 23.

Record reminders are displayed on your Palm OS handheld only. 
They are not displayed on your Windows computer.

• Click the Reminder drop-down arrow and select a date for the 
reminder. To cancel the records reminder, deselect the checkbox.

• Choose a time for the reminder using the At selector.
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• Click the Repeat trigger to open the Repeat Settings dialog and 
specify a repeating reminder schedule for the record.

• Enter a reminder message in the Message field. This message will be 
displayed when the reminder is due.

TIP: To enter a tab character in the message field, type Ctrl-Tab.

Click OK to save the record, or Cancel to discard your changes.
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Using Categories
Categories are used to filter records in the Record View. See “The Record 
View” on page 10.
To create, rename or delete a category, choose the Categories option from 
the Tools menu, or select “Edit categories” from the category list in the 
Record List view.

To add a category, click the New button, and enter the name of the 
category.
To delete a category, select it in the list and click the Delete button.

When you delete a category, the records in that category are moved to the 
Unfiled category.

To rename a category, select it in the list, click the Rename button, and 
enter the new name.
Changes you make to the categories in DataShield are reflected on your 
Palm OS handheld the next time you synchronize.

Printing
To print a record or template, select it in the Record or Template View, 
and click the Print toolbar button or select the Print option from the File 
menu.
To print all records or templates, open the Record or Template View, click 
the Print toolbar button or select the Print option from the File menu, and 
choose the All option.
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Backing Up Your Data
To back up your Ultrasoft DataShield for Windows database, choose the 
Backup option from the File menu.
Later, if necessary, you can use the Restore option from the File menu to 
restore your backed-up database. This will overwrite your current database 
with the data from the backup file.
You should periodically back up your database to a diskette, CD-RW or 
web archive so that it will be safe if your computer’s hard drive should 
fail.

Archiving Records
To archive records and templates, use the Archive option from the File 
menu.
This option will export records that are marked for archive to a file that 
you specify, then delete those records and templates from your current 
DataShield database.
You can mark records and templates for archive by selecting them in the 
Record or Template View, and clicking the Archive button in the toolbar 
or selecting the Archive option from the pop-up menu. You can also mark 
records and templates for archive in the Record and Template Details 
dialogs. See “Record Details” on page 15 and “Template Details” on page 
26.
Later, you can re-import data from an archive file using the Import option 
from the File menu.

Importing and Exporting
Ultrasoft DataShield for Windows will export data to a text file in 
Extended Markup Language (XML)  format, which preserves the complex 
structure of your DataShield data. Many utilities, including Microsoft® 
Internet Explorer, will allow you to work with XML files.
To export the data from your DataShield database, choose the Export 
option from the File menu. You will be prompted for the name of the 
export file, and you can choose whether or not the exported data is to be 
encrypted. Select or enter a file name and click the Save button.
To import data, use the Import option from the File menu. Imported 
records, templates and categories are merged with your current DataShield 
database.
You can import data from a DataShield archive or export file, or from a 
delimited text file, such as a Comma-Separated Values (CSV) file, 
generated by another program.
When you import from a delimited text file, the DataShield Import Wizard 
will display step-by-step instructions, prompt you to describe the file 
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layout, parse the data into columns, and walk you through the import 
process:
• You can specify which delimiters and qualifiers are used in the file.
• The first row of the file can contain column names, which can be used 

to automatically create a new template. Alternatively, you can select 
an existing template or explicitly create a new one.

• If you select an existing template, you are prompted to specify which 
template fields correspond to the imported data columns.

• You can specifiy a column  that contains a category name for each 
record, or select an existing category.

• You can specifiy a column that contains a note for each record.
• If each row contains different kinds of data, you can specify a column 

that contains a template name, or select/create a template for each row 
as it is imported. You can also choose to be prompted to select a 
category and note column for each row.

You can also exchange data between DataShield and other programs using 
copy/paste and drag/drop operations. See “Viewing a Data Record” on 
page 13 and “Record Data Values” on page 14.
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Using Templates

Overview
Ultrasoft DataShield uses templates as a basis for data records. When you 
create a new record, its fields, default settings and reminder schedule are 
based on the currently-selected or last-used template. See “Creating and 
Editing Data Records” on page 14. In addition, the Record View can be 
filtered by template. See “Viewing Your Data” on page 10.
DataShield comes with a set of pre-defined templates that you can use as a 
starting point for your own templates.

Viewing Templates
The Templates View shows a list of available templates.
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To access the Templates View, click the Templates icon in the shortcut 
pane, or select Templates from the View menu.
The list displays each template’s name, and an icon to indicate if the 
template is marked Archived.

Templates that are marked Archived, and their records, are not 
synchronized with your Palm OS handheld, and can be exported and 
removed using the Archive command in the File menu. See “Template 
Details” on page 26 and “Archiving Records” on page 20.

With the preview pane enabled, select a template in the list to display its 
details.
To create a new template, click the New button.
To edit a template, double-click on its name in the list, or select it and 
click the Edit button.
To duplicate a template, click on its name in the list and use the Copy and 
Paste menu commands. Duplicating and modifying an existing template 
can be a quick way to create a new template.
To delete a template, click on its name in the list and then click the Delete 
button in the toolbar, or right-click the mouse on its name and choose the 
Delete command from the pop-up menu.

NOTE: You cannot delete a template that is used by data records. You 
must delete or reassign the data records first.

You can also select a template and use the main menu, pop-up menu, 
toolbar or keyboard shortcuts to cut, copy, paste, archive or print it.

Keyboard shortcuts are displayed in the menus. Mnemonics for buttons 
and other controls are indicated by an underlined character in the button or 
other caption. Windows XP users: press the Alt key on your keyboard to 
highlight shortcut mnemonics.

Creating and Editing Templates
To create a new template, click the New button in the Templates View, or 
use the Copy and Paste menu commands. To edit an existing template, 
double-click on its name in the Templates View list, or click its name and 
click the Edit button. See “Viewing Templates” on page 23.
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When you create or edit a template, the Edit Template View is displayed.

• Enter the name of the template in the Name field.

NOTE: Template names must be unique.

• Click the Add button and enter a field name to add a new field.
• Click the checkbox next to a field name to select whether or not data 

for that field is encrypted in the DataShield database.

NOTE: Unencrypted data appears as plain text to anyone who might 
obtain a copy of your DataShield database. Be sure to encrypt any 
fields that might contain private information.

• Select a field and click the Delete button to remove the field. When 
you click the OK button, the field will be removed from 
corresponding data records.

• Select a field and click the Edit button to rename it.
• Select a field and click the Up or Down button to change the order of 

the field in the list.
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NOTE: When you reorder the fields in a template, the fields in 
related data records are also reordered.

Click the OK button to save or update the template, or click the Cancel 
button to discard your changes.

Template Details
Click the Details tab to view to the template details.

• Click the Show in List drop-down arrow and select a field to be 
displayed in the second column of the Record List View. The record’s 
first field (usually the Description field) is always displayed in the 
first column.

• Click the Record Color and Record Icon selectors to choose a 
default color and icon for the Record View display for records based 
on the template.

• Check the Encrypt Note option to encrypt notes attached to records 
based on the template.

• Check the Archive option to mark the template as archived. Archived 
templates and their records are not synchronized with your Palm OS 
handheld. See “Archiving Records” on page 20.
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Default Reminder Schedule
Click the Reminder tab to set or change the default reminder schedule for 
the template.

• Enter a reminder message in the Message field. This message will be 
displayed when a reminder is due for records based on the template.

TIP: To enter a tab character in the message field, type Ctrl-Tab.

• Click the Schedule trigger to open the Repeat Settings dialog and 
specify a repeating reminder schedule for the template. To cancel the 
schedule, choose None in the Reminder Schedule dialog.

• Choose a time for the reminder using the At selector.

Record reminders are displayed on your Palm OS handheld only. 
They are not displayed on your Windows computer.
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Data Security

Overview
Information that you enter into DataShield is stored in a password-
protected database.
You assign a password when you first run DataShield, and when you lock 
the program, nobody can access your encrypted data without your 
password — not even the software engineers at Ultrasoft. 

Security Preferences
To access the Security Preferences, open the Preferences dialog via the 
Tools menu and select the Security tab.
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DataShield has three pre-defined security levels: high, medium and low. 
Or you can select your own options in the security preferences screen to 
create a custom security level.
• High: DataShield will use the highest security settings to protect your 

data. This also means that you will be required to enter your password 
each time you access the program.

• Medium: The program will select security settings that attempt to 
give the best balance of security and convenience to most people.

• Low: DataShield will use lower security settings. You will have to 
enter your password only infrequently, but your data will not be as 
well protected.

• Custom: Select this option by choosing your own individual security 
settings.

DataShield for Windows supports the following security options:
• Encrypt All: With this option enabled, DataShield will encrypt all 

your data, regardless of the encryption settings in your templates. See 
“Creating and Editing Templates” on page 24.

• Show decrypted data in list: With this option enabled, DataShield 
will decrypt and display encrypted data in the Record View. 
Otherwise, it will mask encrypted data in the list. See “Viewing Your 
Data” on page 10.

• Show decrypted data in preview pane: With this option enabled, 
DataShield will decrypt and display encrypted data in the Record 
Preview. See “Viewing a Data Record” on page 13.

• Create searchable records: With this option enabled, new records 
will automatically have their Searchable attribute enabled. See 
“Record Details” on page 15.
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Changing Your Password
The first time you run Ultrasoft DataShield, it requires that you assign a 
password.
You can change your password at any time using the Change Password 
option in the File menu.

You can choose to synchronize the DataShield password on your 
Windows computer with DataShield on your Palm OS handheld. See 
“HotSync Options” on page 35.
If you use the PIN password format on your Palm OS handheld, you must 
enter the corresponding numerical button values for the password on your 
desktop computer.

You can un-check the Mask checkbox and tap the buttons to determine 
their numeric button values.

6

1

2
3

5
4
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If you use the alpha-numeric password format on your Palm OS® 
handheld computer, your password must be between four and sixteen 
characters in length. If you use the digits-only or PIN format, it must be 
between four and six characters in length. A longer password provides a 
higher degree of security. For more information, see the DataShield for 
Palm™ Powered Handheld Computers User’s Guide.

IMPORTANT: If you lose or forget your password, it cannot be removed 
or recovered. Record your password in a safe place.

Locking DataShield
Ultrasoft DataShield will lock automatically when you close the program.
You can lock DataShield at any time using Lock Now command from the 
File menu, or the Lock Now toolbar button. DataShield will lock 
immediately.
When DataShield is locked, you must re-enter your password to access the 
program.
If you cancel the password prompt without entering your password, you 
can use the Unlock command from the File menu or the Unlock toolbar 
button to regain access to the program.
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Synchronization

Overview
Ultrasoft DataShield for Windows includes a conduit to synchronize your 
entries with DataShield on your Palm OS handheld.  The conduit is 
installed when you run the Ultrasoft DataShield setup program on your 
Windows computer and choose the Full Setup option.
You can set the Ultrasoft DataShield synchronization preferences using 
the Palm Desktop Custom dialog, or using the Preferences dialog via the 
Tools menu in DataShield for Windows.
To access DataShield synchronization preferences using the Palm Desktop 
Custom dialog:
1. Open the Start menu and choose Programs > Palm Desktop > Palm 

Desktop.
2. To open the Custom dialog, open the HotSync menu and choose 

Custom.

3. Make sure that your Hotsync ID is selected in the top drop-down list.
4. Choose DataShield from the conduit list and click the Change 

button.
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Setting the Synchronization Properties
The DataShield Properties dialog includes the following tabs.

• HotSync Actions
• HotSync Options
• The About Page

HotSync Actions
The HotSync Actions properties tab allows you to specify the action that 
HotSync will take the next time you synchronize Ultrasoft DataShield.

• Synchronize the files: changes to your DataShield database are 
exchanged between your Windows computer and your Palm OS 
handheld.

• Desktop overwrites handheld: the data from your Windows 
computer replaces the data on your Palm OS handheld.

• Handheld overwrites desktop: the data from your Palm OS 
handheld replaces the data on your Windows computer.

• Do nothing: no DataShield synchronization takes place.
• Set as default Hotsync Action: makes the selected option the default 

for subsequent HotSync operations.
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• Verbose logging: additional information is recorded in the HotSync 
log.

• Show progress: displays a dialog that shows the synchronization 
status.

• Recovery mode: forces all records, not just modified or new records, 
to be uploaded from the Palm OS handheld and does NOT update the 
data on the handheld, so that you can try again if necessary. This can 
be used to try to recover lost data from the Palm if, for example, your 
PC hard drive crashes. Results are not guaranteed.

HotSync Options
The HotSync Options properties tab allows you to specify how you want 
your DataShield database synchronized.

• Synchronize password with handheld: your Ultrasoft DataShield 
password is synchronized between your Windows computer and your 
Palm OS handheld. If you change your password on one platform, the 
change is reflected on the other when you synchronize.

• Synchronize security settings with handheld: your security 
settings are synchronized between your Windows computer and your 
Palm OS handheld. See “Security Preferences” on page 29.
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The About Page
The About tab in the DataShield Properties dialog displays the Ultrasoft 
DataShield conduit version, and your HotSync ID or user name. This is 
also where you enter your Ultrasoft DataShield registration code to 
activate full synchronization.
You can also enter your registration code in DataShield for Windows via 
its About dialog, or in its Preferences dialog on the Registration tab. See 
“How do I register Ultrasoft DataShield?” on page 38. 
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Helpful Hints and Troubleshooting

Frequently Asked Questions
This chapter contains a selection of Frequently Asked Questions. For the 
answers to more questions, or to get online assistance, please visit the 
Ultrasoft DataShield support web site at http://support.ultrasoft.com/.
• System Requirements
• How do I register Ultrasoft DataShield?
• What should I do if I forget my password?
• What if I lose my registration code?



Ultrasoft DataShield Helpful Hints and Troubleshooting   •   38

System Requirements
Ultrasoft DataShield for Windows requires Microsoft® Windows® 98 or 
later. 
DataShield for Palm OS handhelds requires Palm OS® 3.0 or later. 
The User’s Guide was created using Adobe Acrobat 5.0, and can be 
viewed with Acrobat Reader 4.0 or later. Visit www.adobe.com for a free 
copy of Acrobat Reader.

How do I register Ultrasoft DataShield?
You can purchase an Ultrasoft DataShield registration code at the web site 
where you downloaded the software, or at http://www.ultrasoft.com. You 
will be asked to provide your HotSync ID.
To locate your HotSync ID, start the HotSync application on your Palm 
OS® handheld device, and look in the upper-right corner of the screen.

Your registration code is based on your HotSync ID, so that your licensed 
copy of DataShield will run only on your Palm OS® handheld computer.
When you have obtained your registration code, enter it in any one of the 
following locations:
• in the About screen of the DataShield application on your Palm OS® 

handheld device, or 
• in the About dialog in DataShield on your Windows computer (click 

the Register button), or
• in the Register tab in the Preferences dialog in DataShield on your 

Windows computer, or
• in the About tab in the DataShield conduit settings (see “Setting the 

Synchronization Properties” on page 34).
When you enter your registration code into one DataShield program, it 
will be synchronized with the others.

What should I do if I forget my password?
Ultrasoft DataShield is designed to be secure. If you lose your password, it 
cannot be recovered or removed. Your only option will be to delete and 
reinstall DataShield, and re-create your data.

What if I lose my registration code?
Visit the Ultrasoft secure web server at http://secure.ultrasoft.com/ to retrieve 
it. You’ll need your registered e-mail address to access the server.
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Getting Help

Technical Support 
If you cannot find the answer to your question in the online help or this 
user’s guide, you can get help from several other sources including the 
Frequently Asked Questions, using a database search, submitting your 
question to other users, and sending an e-mail to Ultrasoft support.

Frequently Asked Questions
If you have difficulty with Ultrasoft DataShield, please take a look at the 
Frequently Asked Questions page at the Ultrasoft DataShield web site:
http://support.ultrasoft.com/

Search for Help
You can look for your answer in our up-to-date solution database, where 
we store all questions and answers. If you are unable to find the answer 
using the database, post a question online and we’ll help you personally.

Chat
For the fastest response, chat with Ultrasoft support and other Ultrasoft 
DataShield users, by visiting:
news://news.ultrasoft.com/ultrasoft.datashield
or:
http://support.ultrasoft.com/forum

E-mail Support
If you send e-mail to support@ultrasoft.com, our support robot will read 
your e-mail and suggest solutions.
Please include the following information in your message:
• A clear description of the problem you’ve encountered
• Any error messages you’ve seen
• Ultrasoft DataShield version
• Handheld computer type, Palm OS version, and HotSync version
• A list of other programs you have installed on your organizer
• Desktop OS version (e.g. Windows ME, Mac OS 9, Linux)
If the automatic response does not answer your question, please click the 
link near the bottom of the message to let us know.
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